본문 바로가기
iaa.dev/AWS

AWS Lightsail 의 LAMP 스택 PHP 8로 업그레이드하기

by chopper.kid 2022. 1. 16.

현재 Lightsail 의 인스턴스 생성시 LAMP 선택은 PHP의 선택지가 7로만 되어있습니다.

OS 만 선택해서 이미 사용하고 계신분들도 계시고 , LAMP 로 생성하신분들도 계실텐데

LAMP 로 설치해서 PHP 8 로 올리시고 싶으신분들을 대상으로 하는글입니다.

 

Laravel 9 는 PHP 8 이상을 요구하고 , 패키지들중에서도 PHP 8 을 요구하는것들이 많아졌습니다.

이것저것 알아보다 아래 사이트에서 설치하는 방법이 나와있는데 , 매우 간단하게 가능합니다.

PHP 8로 하실분들 한번 고려해보시기 바랍니다.

 

 

Upgrade to the latest PHP or the latest LAMP stack within the Lightsail AWS service?

Keywords: LAMP/MAMP/WAMP - Amazon Web Services - How to - Upgrade Description: NOTE: I have looked across multiple sources and the following question has been addressed however I’m yet to see a clear concise answer and seems to be avoided by Bitnami engi

community.bitnami.com

 

sudo /opt/bitnami/ctlscript.sh stop

sudo mv /opt/bitnami /opt/bitnami.back

위사이트에 나온 버전이 PHP 7 로 설명되어 있어서 8 버전으로 바꾸었습니다. 현재 8.1.1 이 최신 버전인듯합니다.

cd

wget "https://bitnami.com/redirect/to/1855335/bitnami-lampstack-8.1.1-0-linux-x64-installer.run"

chmod +x ./bitnami-lampstack-8.1.1-0-linux-x64-installer.run

sudo ./bitnami-lampstack-8.1.1-0-linux-x64-installer.run

 

2022년 1월 24일 추가 수정

1월21일 새로 PHP가 업데이트되면서 여기도 업데이트되었습니다. 8.1.2 버전으로 설치하고 테스트해보진 않았지만 크게 다를건없기에 아래 버전으로 테스트하실분들은  아래로 해보세요.

cd

wget "https://bitnami.com/redirect/to/1915288/bitnami-lampstack-8.1.2-0-linux-x64-installer.run"

chmod +x ./bitnami-lampstack-8.1.2-0-linux-x64-installer.run

sudo ./bitnami-lampstack-8.1.2-0-linux-x64-installer.run

 

 

 

스택 인스톨은 다음 디렉토리로 지정하고 , 비번을 지정합니다.

 

/opt/bitnami

 

데이터베이스가 이미 있으면 백업을 해둡니다.

https://docs.bitnami.com/aws/components/mysql/#how-to-restore-a-database-backup

 

Bitnami Stacks for AWS Cloud

 

docs.bitnami.com

 

아파치를 다시 시작합니다.

sudo /opt/bitnami/ctlscript.sh restart apache

 

 

이게 끝입니다.

저도 간단한 체크정도만 해봤는데 크게 문제는 없는듯합니다.

이미 서비스를 돌리고 있는 분들은 모험을 걸기엔 좀 그렇죠?^^

 

LAMP 를 새로 깔면서 이번 기회에 PHP 8 로 하실분들은 한번 도전해서 해볼만 합니다.

 

반응형
SMALL

'iaa.dev > AWS' 카테고리의 다른 글

AWS Lightsail 의 LAMP 스택 PHP 8로 업그레이드하기  (0) 2022.01.16

댓글0